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Getting started 

This chapter explains the information you need to log on and use the 
Automated Lightning Mapping System (ALMS).  ALMS allows you to 
download near real time lightning location information from the Bureau of 
Land Management lightning data server on the Internet and then view that 
data using ArcMap 9.x. Topics include: 

•  Before you begin 
•  Installing ALMS 
•  Terms and concepts. 

Before you begin 
Before using ALMS, you must feel confident that: 

• You have requested “Administration” privelege to log into the target 
client PC where you will be installing ALMS.  

• You are familiar with your personal computer and functions keys, and 
understand personal computer concepts. 

• You are familiar with Windows NT, Windows 2000 or Windows XP and 
can log on and log off. 

• You have basic skills using ArcGIS 9.x or “ArcMap” and an Internet 
browser. 

• You have assured ArcGIS 9.x or “ArcMap” starts and runs on your target 
client PC. 

 

Software and hardware requirements 
You must have the following hardware and software to run ALMS: 

Item Minimum Requirement Recommended 

Operating System Windows NT, Windows 2000, Windows XP WIN 2000 or XP

Internet Browser MS Internet Explorer 5.0 or newer IE 6.0 

Internet connection 9600 or higher 56K or higher 

mapping software ArcGIS 9.0 or 9.1 ArcGIS 9.1 

CPU Pentium 800 MHz Pentium 1 GHz 

monitor color support 256 65,536 
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monitor resolution 640 x 480 1024 x 786 

RAM 256 MB 512 MB 

hard disk space available 50 MB same 

mouse yes same 

printer any - windows compatible color laser 

 

Installing ALMS 
This section outlines the basic instructions to install ALMS for Windows NT, 
2000 and XP operating environments. Before starting the installation process, 
close all other applications. 

To download the ALMS installation file from the Internet 

1 Ensure you have logged into the target client PC as a user with 
“Administrator” priveleges. 

2 Start your Internet browser.  In the address box, type  
http://www.fs.fed.us/fire/planning/nist/distribu.htm , and then press 
ENTER. 

3 Scroll down to Software, and then click ALMS V4.0. 

4 Click the installation file, and then save it in the folder of your choice. 

 

For Forest Service users, save the ALMS_V4.exe file in 
C:\fsapps\fsprod\fam\ALMS  For all others, follow your agency’s guidelines. 

 

 

5 The file ALMS_data.exe is also located in the Software folder.  This 
file  contains additional data layers that can be used with ALMS which 
includes federal lands boundaries.  ALMS is distributed with the default 
layers of Capitals, Counties, Freeways, Major Cities, and States.  You 
may download this file now or at a later time. 

6 IF you downloaded ALMS_data.exe, navigate to the folder where you 
saved the file and double-click on the file.  Extract the files to a folder of 
your choice.  Forest Service users extract to 
c:\fsapps\fsprod\fam\alms\data. 
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To install ALMS V4.0 

1 From your personal computer, locate the folder that contains the file that 
you downloaded called ALMS_V4.exe. 

2 Double-click ALMS_V4.exe. 

3 Complete the installation process as instructed on your screen. 

 

 

The following screen shows the first ALMS Installation dialog box. 

 
 

There could be a delay between this window and the following one. Please 
be patient, the installer is checking your system for the location of ArcGIS 
and other components. If the installer fails to find one of the required 
components it will present you with an error message telling you how to 
proceed.
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The following screen shows the Welcome dialog box.  Click Next to 
continue the installation process. 

 
 

The following screen shows the Program Installation Folder dialog box.  
Verify that the Program Installation Folder for the ALMS software is correct, 
and then click Next to continue the installation process.  Press Change only 
if you would like to select a different installation folder. The folder must be a 
hard drive on the local workstation. Forest Service users should keep the 
default installation folder. 
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The following screen shows the Default Data Folder dialog box. Verify that 
the data folder is correct and click Next to continue the installation process. 
Press Change only if you would like to select a different Data folder. This 
folder can be on a local hard drive or on a network drive. Forest Service 
users should keep the default Data folder. 

 
 

The next screen allows you to review the installation settings you have 
chosen.  Press Install to continue or Back to go to a previous screen and 
change a setting. 
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As the installation continues, you will see the following screen. 

 
 
 
When the installation is complete, the following screen will display.  Click 
Finish to complete the installation. 
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To configure your time zone on the BLM lightning data server 

Perform this task only if you have not previously done so! 

1 Start your Internet browser. 

2 In the address box, type http://www.nifc.blm.gov, and then press 
ENTER. 

3 On the Wildland Fire Management Information Home Page, click 
Lightning. 

4 On the BLM Lightning - Logon screen, type your Username and 
Password, and then click Logon. 

5 On the BLM Lightning - Successful Logon screen, click User 
Preferences. 

6 Under Time Zone Selection, select the appropriate Time Zone and 
Daylight Savings Time preference, and then click Update Preferences. 

7 When finished, click Logoff, and then exit your Internet browser. 

The following diagram shows the Wildland Fire Management Information 
Home Page. 

 
The following diagram shows the BLM Lightning - Logon screen. 
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The following diagram shows the BLM Lightning - User Preferences screen. 
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To set up ALMS 4.0 in ArcMap 
 
When ALMS 4.0 was installed, an ALMS dll is registered and added as an 
extension to ArcMap.  The ALMS Tools toolbar is then available to be 
turned on within ArcMap. 
 

Before starting this task, log off Lotus Notes to avoid potential memory 
conflicts. 

  

1 Click Start, point to Programs, point to ArcGIS, and then click 
ArcMap. 

2 Turn on the ALMS Tools toolbar by selecting View>Toolbars and select 
ALMS Tools.  You will see the toolbar pictured below.  The toolbar can 
be placed anywhere on your screen or into the header section with the 
other toolbar buttons.  To move the toolbar, left-click in the upper blue 
section, hold the mouse down and drag the toolbar to the desired 
location. 
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3 From the ALMS toolbar, select ALMS>Set User Defaults.  The other 
ALMS Tools options will not function until the defaults are set.  You 
will be presented with the following screen. 

 
 

ALMS Defaults are specific to the Windows userid currently logged in.  
Individual users must each initially set up their ALMS defaults.  

 

Enter the information required in the following sections and press OK when 
finished.  Press Cancel to exit this screen without saving any changes. 
 

 User Information:  enter your BLM Lightning Server Username, and 
then type your BLM Lightning Server Password.  Remember the 
password is case sensitive. 

 Download Data Path: Select the path where you would like the 
downloaded lightning data files to reside. This path can be set to any 
directory accessible by the user that has read and write permission. 

 Default Lightning Data Symbol: You may select Lightning, Dot or Box 
as the default symbols.  Also select a size for the symbol.  For advanced 
ArcMap users, this symbol could also be changed within ArcMap. 

 Alms Default Environment: The items in this section are the basic 
settings required to map the lightning data.  If you are an advanced 
ArcMap user and are using the lightning data with an existing project 
or other data sources, you may want to keep your existing project 
settings. 

 Set Albers US Data View Projection – checking this box sets or 
changes the data view projection for the project to Albers US Data.  
Only check this if you do not have a projection already set and would 
like to use this projection for the ALMS data and any other data you 
are mapping in this project. 

  Add Default Alms Map Data – checking this box adds the default 
ALMS layers to your project.  The default layers are: Capitals, 



Automated Lightning Mapping System User’s Guide Using ALMS 

February 23, 2006 11 

Counties, Freeways, Major Cities, and States.  If any of these layers 
already exist, the program will replace them only if they are newer.  
Any other existing layers will not be affected.  Other data layers are 
available including federal boundaries and can be downloaded from 
http://www.fs.fed.us/fire/planning/nist/distribu.htm. 

 Setup the Default ALMS Layout View – checking this box sets the 
layout view to a default view supplied by ALMS.  Checking this box 
will replace any existing layout view!! 

 

 If you chose to Add Default Alms Map Data, a map showing the United 
States will be displayed.  Any layers that are not visible will be activated 
after zooming into the appropriate scale. 

 
 

4 Save this map project before exiting.  Proceed to the Using ALMS 
section of this guide to begin mapping lightning data. 

 

You have just successfully installed ALMS!  Next, complete the clean up task 
and then you are ready to use ALMS. 
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To clean up 

1 On the Start menu, point to Programs, and then click Windows 
Explorer. 

2 Open the folder that contains the install file ALMS_V4.exe. 

3 Right-click ALMS_V4.exe, select Delete, and then click Yes. 

To log off ALMS/ArcMap 

•  On the File menu, click Exit. 
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Terms and Concepts 
This section identifies some of the key toolbars and menus that you will be 
using in ALMS 4.0. 

Screen terminology 
The following diagram shows the ArcMap/ALMS screen and screen 
elements. 
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ArcMap/ALMS Toolbar 
The following diagram shows the buttons that are available on the ArcMap 
and ALMS toolbar.  Each button allows you to perform a specific function.  
When you hover the mouse over a particular button, a description of that 
button’s function displays in a tool tip over or next to the button. 

 

Alms Tools

Save Project

Zoom In

Zoom Out
Zoom Full Extent

Measure

Download and Map Lightning Data

Set the Area of Interest

Alms Tools

Save Project

Zoom In

Zoom Out
Zoom Full Extent

Measure

Download and Map Lightning Data

Set the Area of Interest

 

 

 

For more information about using toolbar buttons, refer to your ArcMap 
user’s guide. 
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Using ALMS 

This chapter explains some of the basic functions you can perform in ALMS.  
Topics include: 

•  Starting ArcMap/ALMS application 
•  Downloading lightning data 
•  Setting the area of interest 
•  Perfoming Batch Imports 

Starting ArcMap/ALMS 
You may want to create a shortcut of ArcMap to save time starting the 
application! 

To start ArcMap/ALMS 

1 Click Start, point to Programs, point to ArcGIS, and then click  
ArcMap. 

2 Open the existing map that you saved during the installation steps or start 
with a new empty map.  If you start with a new empty map, you will 
need to go through setting the ALMs defaults again.  See the previous 
section, Getting Started>To set up ALMS 4.0 in ArcMap>Step 3 for 
instructions on setting ALMs Defaults. 

3 If the ALMS Tools toolbar is not showing, on the View menu, click 
Toolbars and select ALMS Tools. 
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Adding Other Data Layers 
ALMS is distributed with the default layers of Capitals, Counties, Freeways, 
Major Cities, and States.  The additional layers available for download are: 
NPS Units, National Forests, FWS Units, and BLM Resource Management 
Units.  If other data layers are needed the data must reside on the client or 
be available as a map service on the Local Area Network or the Internet. 

  To add data Layers stored on the Local Hard Drive: 

1. From ArcMap/ALMS.  Select File>Add Data.   

2. Browse to the folder where the data layers are stored and select the 
layers (.lyr files) you would like to add as shown in the screen below.  

ArcMap sets the projections for map layers “on the fly” to the projection set 
for the Data View as the data is added.  If the layers do not have associated 
projection information they will not be projected on the fly.  You may get 
warning messages if layers being added have a different datum than the one 
currently set for the Data View.   The warnings can usually be ignored as 
ArcMap will automatically choose a datum transformation. 
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Setting the Area of Interest 
1 Click the red rectangle on the ALMS Toolbar. 

2 Click, hold, and drag to create a rectangle around the area of your choice. 

The screen below shows an Area of Interest created in western Montana.  If 
an area of interest is set prior to downloading lightning data, the download 
will only include data for the area delineated.  The area of interest is stored in 
the users profile and will remain set until it is changed. 
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Download and Map Lightning data 

To download lightning data 

1 Click the yellow lightning symbol on the ALMS Toolbar or select 
ALMS>Download Data.  The following screen will be displayed. 

 
 

2 On the Lightning Data Download dialog box, enter the desired 
download parameters: 

 Time Frame: The initial values are the Previous 2 Hours from the 
current workstation date and time.  The values can be entered 
manually or adjusted using the “Previous 24 Hours”, “Previous 2 
Hours” and “Now” buttons.  The “Now” button sets the End Time to 
the current workstation time. After pressing the “Now” button you 
will need to set a new start time. 

 Bounding Rectangle:  Displays the upper and lower boundaries 
defined by the “Area of Interest” rectangle.  You can change these if 
you desire. 

 Polarity: Indicates polarity values that will be included in the 
datafile.  The default value is “Both”.  Click the botton next to the 
desired value. 

 Status:  Indicates the status of the download and import process as it 
progresses. 

3 Click Download Data to begin the download. 
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The following screen shows the downloaded lightning data displayed on the map. 

 

Reviewing specific areas of interest 
This section explains how to use toolbar buttons to review specific areas of 
interest.  Use these buttons in combination to quickly identify the specific 
area of your choice. 

Using the zoom buttons 
There are four different zoom buttons that you can use to navigate around the 
map: 

•  The zoom buttons that show arrows pointing toward or away from a 
center point allow you to zoom in or zoom out from the center of the 
display.  These two buttons are on the first row of the toolbar. 

•  The zoom buttons that show a plus sign (+) or minus sign (-) within a 
magnifying glass allow you to zoom in or zoom out from a point you 
click on the map.  These two buttons are on the first row of the toolbar. 
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To zoom in or zoom out 

•  Click the zoom button of your choice, and then click on the map location 
of your choice.  Notice that various layers are defined as scale dependent 
and displayed as the map is zoomed in. 
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Performing Batch Import 
 
The batch import utility can be used to import previously downloaded ascii data files created 
via the external lightning down executable (lghtndown.exe).   
 

1 Select ALMS>Batch Import on the ALMS Toolbar. 

2 Browse to the location of the data files using the Batch Import screen as 
shown below.  Select one or more files for import.  

3 Press OK to import.  The text files will be processed into shapefiles and 
other supporting files then displayed as layers in the project. 

 
 


